Merrill Communications LLC
Call Us: 1-855-375-7157
MERRILL BRIDGE RELEASE 7.3 AND UPGRADING TO .NET 4.6.2

Merrill Bridge provides the highest level of security for your confidential data. To achieve this and enforce the most secure Advanced Encryption Standard ciphers via the TLS 1.1 and TLS 1.2 protocols, Merrill requires all computers using Windows 7 and Windows 10 to use the .NET 4.6.2 or higher Framework. Your computer may already be upgraded to this standard but since Merrill Bridge requires it, we’d like you to check with your IT team to confirm you are using .NET 4.6.2 or higher and if you are not, have your IT team upgrade you to this. This does not affect other applications that may use a different version of .NET. Microsoft has designed them so one computer can support multiple versions of .NET.

Contact your IT team to have them check if you require an upgrade to .NET 4.6.2. Your IT team can assist you in this upgrade if required. Click here for more information. If you or your IT team would like to discuss this release, please contact Merrill Support at support@merrillbridge.com or 1-855-375-7157.

If you have not yet installed .NET 4.6.2 when attempting to load Merrill Bridge you will be prompted to download and install the .NET 4.6.2 Framework and reboot your computer.

Note, you cannot access Merrill Bridge 7.3 without first ensuring .NET 4.6.2 is installed.


MERRILL BRIDGE RELEASE 7.3 AND OFFICE 64 BIT

In addition to upgrading to .NET 4.6.2, users of a 64-Bit version of Microsoft Office may need to do an additional step, before loading Merrill Bridge. Users whose Microsoft Office was upgraded from 32-Bit to 64-bit via the upgrade option (versus having uninstalled 32-Bit and installing 64-Bit) will have a duplicate registry key that needs to be removed. Contact your IT team and provide them the detailed information that can be found here.

Login